Missing fuse question

Discussion in 'Sparky's corner' started by jaye, Aug 9, 2017.

  1. jaye

    jaye Well-Known Member

    After a year of restoring & repairing my 1969 Skylark is finally drivable; last week I installed the headlights today I turned them on and no lights I haven't looked to check the problem however I did see one thing that may be the issue. In the fuse panel the top left fuse is missing under it is power accsy & bat can someone tell me what this fuse is for. I also installed a new wiper motor which worked & parked like it's suppose to. This morning I installed the wiper blades and the wipers will not turn on, took the wiper arms off and they still will not turn one.
    Any ideas on any of this it will probably be next week before I can get back in the garage to check anything.
  2. BuickV8$Mike

    BuickV8$Mike Well-Known Member

    The headlight issue could very well be the foot switch. I have a '69 also and that solved my problem. Let me know what you find with the wipers because I have the same problem. :)
  3. 87GN_70GS

    87GN_70GS Well-Known Member

  4. 87GN_70GS

    87GN_70GS Well-Known Member

    The missing fuse you're referring to is for power windows, door locks, and seats
  5. jaye

    jaye Well-Known Member

    I went into work a couple hours early and got some things completed, pressed the dimmer switch and the lights now work on dim & bright. Changed the fuse in the wiper motor and it still wouldn't work. When I started to take it off I tried one more time and it miraculously started working again. The ground is good. Drove a few miles which went very well when the rain stops I'll go on a road trip on the interstate.

Share This Page