Brake light and turn signals

Discussion in 'Sparky's corner' started by Aus91R, Apr 20, 2020.

  1. Aus91R

    Aus91R Well-Known Member

    Do you guys know how to get to the brake light on a 69 Lesabre? I am pretty sure mine just burnt out. Also, all of my turn signals went out, where should I look first for diagnosing this? I don't have any manuals unfortunatly, so any help is appreciated, thanks!
     
  2. buick64203

    buick64203 Just plum crazy Staff Member

    If you cant get to the sockets from behind, you have to remove the lens. Do the hazzards work? If so, swap the hazzard flasher for the turn signal flasher and see if they work
     
  3. Aus91R

    Aus91R Well-Known Member

    I will give that a try. Thanks.
     
  4. Aus91R

    Aus91R Well-Known Member

    Just found out the hazards don't work either. I looked around the tail light to see if I could find any screws, I didn't. I did find two bolts under a rubber strip that sits on top of the bumper. It looks like that might be what's holding the tail light in place.
     
  5. Aus91R

    Aus91R Well-Known Member

    Figured the brake lights out. You can get to them from behind, but not in the trunk. They are between the bumper and the body.
     
  6. buick64203

    buick64203 Just plum crazy Staff Member

    Id throw a new flasher in it and see if that fixes the turn signals.
     
  7. Aus91R

    Aus91R Well-Known Member

    I will do that next.
     
  8. Aus91R

    Aus91R Well-Known Member

    I put a new flasher in, but still nothing.
     
  9. LARRY70GS

    LARRY70GS a.k.a. "THE WIZARD"

    TrunkMonkey likes this.
  10. Aus91R

    Aus91R Well-Known Member

    Thanks! I checked the fuse and it tested fine. It looks brand new actually. I have a manual on its way.
     
    Last edited: Apr 23, 2020
  11. Aus91R

    Aus91R Well-Known Member

    Okay, tell me if this means anything. I went outside to put the fuse back in, and all of the hazard lights were blinking. The hazard switch had accidentally been left pushed in the other night when I tried to see if they worked. So, the hazards are working just fine now that the fuse is out.
     
  12. jaye

    jaye Well-Known Member

    Maybe Sound like a short somewhere ; with the fuse out there shouldn’t be any power
     
  13. LARRY70GS

    LARRY70GS a.k.a. "THE WIZARD"

    You have 3 separate 20 Amp fuses for the Tail lights, Brake lights AND Hazards, and Signals. You can look at glass fuses and immediately see if they are blown. There should be no power without the fuses installed so I am confused by your post.
     
  14. Aus91R

    Aus91R Well-Known Member

    I'm confused too. I pulled the fuse for the blinkers it looked fine. It definitely is not blown, but when I pulled it out the hazards started blinking. I dont know why they would do that. The hazards were not working when the fuse was in place. They only started blinking when I took the fuse out.
     
  15. LARRY70GS

    LARRY70GS a.k.a. "THE WIZARD"

    Do the brake lights work without the fuse?:) They are on the same fuse as the Hazards.
     
    Last edited: Apr 23, 2020
  16. Aus91R

    Aus91R Well-Known Member

    Hahaha, I should have looked! I put the turn signal fuse back in, and the hazards still work, so maybe it was just some kind of fluke? I have all the brakelights working now as well. Still no blinkers though. Could it be the turn signal switch?
     
  17. buick64203

    buick64203 Just plum crazy Staff Member

    Are you sure you replaced the turn signal flasher and not the Hazzard flasher?
     
    Aus91R likes this.
  18. LARRY70GS

    LARRY70GS a.k.a. "THE WIZARD"

    It's WAY more likely that the signal flasher unit is bad. There are 2 flasher units, one for the hazards, one for the signals. Both the same flasher unit, so swap them and see if your signals work and the hazards don't.:)
     
    Aus91R likes this.
  19. Aus91R

    Aus91R Well-Known Member

    okay, I think I see what you guys are saying. I will give that a go, and see if that works! Thanks for all the help, yeah I may have replaced the hazard flasher and not the blinkers! I will check it out.
     
  20. Aus91R

    Aus91R Well-Known Member

    Also, and this may seems silly, but if the flasher I got is in the spot for the hazards, then where do you plug it in for the turn signals?
     

Share This Page